connect to .dbf files

.net , databases Indonesia
  • 10 years ago
    i'm newbie in VB prog.
    i try and out of idea how to open .dbf files that create by Clipper Programming
    can anyone help me?



  • 10 years ago

    If you are not using the Clipper program anymore then i would suggest converting the .dbf file to MS Access.  Simple create a new Access file and use the import function in Access to create a table from each .dbf file.  Then you can use all the standard file access and recordset functions. 

    PS  i programmed in Clipper for about 10 yrs and loved it.  But i had to give it up when everything went GUI.

    Wes

  • 10 years ago

    I do not know exactly how to do it in .Net.

    With VB i've had good results using ODBC and connecting as Dbase III files. Than use ADO to access recordsets and copy to usefull formats.

    DBF files have a fixed recordsize, after the fileheader (I believe 1024 bytes) wich describes this layout. A binary filereader can explain a lot about these files.

    It must be possible to open such a file using normal file-streaming in .Net.

    Consider writing to these files, since there are other options, like Mysql, sqlServer etc. Clipperfiles are not very usefull anymore.

    Similar feelings to you Wes!

  • 8 years ago

    Hi buditan, if you are still interested, I recommend that you try the [url=http://www.recoverytoolbox.com/mssqlserverrepair_database.html]mssql 2005 repair[/url] program,it is a good solution, if you experience any difficulties with dbx files and their conversion. Hope this helps

Post a reply

Enter your message below

Sign in or Join us (it's free).

Contribute

Why not write for us? Or you could submit an event or a user group in your area. Alternatively just tell us what you think!

Our tools

We've got automatic conversion tools to convert C# to VB.NET, VB.NET to C#. Also you can compress javascript and compress css and generate sql connection strings.

“The difference between theory and practice is smaller in theory than in practice.”