A Giant Hurdle blocks my Giant Leap! (MSDE 2000)

msde , sql , access India
  • 11 years ago

    Hello Friends… Before going into why I am writing this, first I want to confess one thing. I am not a very experienced professional like some of you reading this post. I am just a beginner in learning Ms-Office. As a sincere amateur, I so far explored most of the options in Ms-Word, A little bit of Ms-Excel and a Fair amount of Ms-Access. My expertise includes both the manual options and also the objects Models of the above said applications. Ok. Let’s come to my current scenario. From my initial stage onwards (in Ms-Access) I often came across two types of help content in access help. Wherever I go in Access help, it categorized by “for mdb” and “for adp”. To say the fact, I never even read beyond the mdb section. But as I was curious to know what adp really is. After sometime I came to know that it is a different type of Database file (called Data-project normally) we can create in Ms-Access. I also got some information about MSDE. I even tested in one time at my home (just to feel it). While trying at my home, I did not have any problem in installing MSDE or upsizing my mdb files into adp and also hosting that converted mdb into the MSDE Server. The main reason for me to experiment all these without any trouble is that I did not have a network in home. I just installed the MSDE in stand-alone system and using the adp in the same system itself. At that time I was not even aware of the two authentication systems. I was (‘was’) confident that I can easily achieve the same things I experimented in home anywhere at anytime. In fact, I even expected a chance to implement my expertise from my home experiment. Three years went by; I did not get any opportunities to delve me into that subject for further exploration. Before two months, I was allotted to a creation of Ms-Access Database system. My TL clearly explained the scenario and requirements of the project in the beginning itself. He again and again mentioned that we have to implement a distributed access to that system. Since I experimented the MSDE already in my home. I thought I will be very easily to install, configure and to connect to a MSDE in an office environment too. All the Basic Designs, Forms, and Report Generations are finished now. It’s the time for Upsizing that Database into an SQL database and to host in the MSDE server finally. But I never expected that this will be this much tougher. Even installing the MSDE played with my guts. Let I rewind my past one week. Day 1: My TL leader instructed me that there will not be any login dialog box for the system. He told me to capture the windows Login id instead. I thought that Windows Authentication will be useful here. But I have done a mistake here. I thought I will be very easily to achieve this in MSDE. My TL helped me installing the MSDE in my system. Because my account is having admin rights. After installing and restarting the machine. TL again logged into his account. It was working fine. I thought every thing was over. Day 2: I was very happy that installing and configuring had been very easily and planned to upsize the database today. After logging in to the system with my account. I was shocked to see that the MSDE icon in the system shows ‘Not Connected’. I checked the LAN cable. It was properly connected. No problem in the network at all. Then I again requested my TL to login in with his account. He logged in. It was working fine. I shocked. Why a software which is running and connecting in an admin account is running but not connecting in a limited account. I am really confused. But I had hurried anyway. So I requested my TL to install the MSDE in a shared system. This time after installing in the system we checked there itself. I was very happy that we were getting access both through the ‘Windows Authentication’ and also using the ‘SQL Server Authentication’ modes. Again I thought every thing was over. Day 3: Today, I was some what enthusiastic that I going to work in a new thing today. I logged in my system with my account (limited) and tried to access the Database Server. It showed error. I thought the same thing which prevents a limited user to install and host an MSDE server is also preventing a limited to user to connect to remote server. So I requested my TL to logging with his account in my pc. First we tried ‘Windows Authentication Mode’. It is not successful. Then we tried the ‘SQL Server Authentication Mode’. ‘Success’ It was connecting and show the Databases in it. Again I thought all my problems are solved and decided that we need an administrator to install or to connect a server. Day 4: I requested my TL to login in my system and requested another admin to login in the central system. ‘Not working’. ‘It’s clear to me!’ It only works under one scenario. The system where the server is running and in the system where the server is being connected needs to be logged in by the same account. But I know this must not be happening. Otherwise there is no need for MSDE here. I started to see whether any people out there in this world facing or faced the Same problem. Though I saw the ‘SQL’ everywhere but did not see the ‘MSDE’ word often. After an extensive search of more than 4 hours I crossed one link suggesting me to configure the ‘Server Network Configuration utility of MSDE ‘SVRNETCN.exe’ and to enable to Network ability in the Server. I wondered why we need a server unless it is a not configured for network protocols. Later I came to know that MS-SQL is a commercial product for Microsoft. But not MSDE. I am clear that I can not any support for MSDE from Microsoft. Finally I ran the SVRNETCN.exe in server and enabled the ‘TCP/IP’ protocols and the ‘Named Pipes’. After restarting the system I was properly able to connect in the system which is hosting the server and also in the system where it is being connected. But Not through ‘Windows Authentication Mode’ but through ‘SQL Authentication Mode’. Anyway it’s running. Day 5: Today. The system where MSDE in installed and properly configured was formatted and also had Visual Studio.Net with SQL Express in it. So we replayed the installing procedure for MSDE again. This we had to pass the instance along the disablenetworkprotocols=0 along with the usual sapwd = ‘somepass’ and securitymode = SQL. It works properly in the server system. But not in any other system. It tried to connect with specifying the server/instancename. Today is Day5. I know I was in a same kind of situation when I first started to learn the Ms-Access. Now it’s the turn for me to learn MSDE. I know that MSDE requires a lot more effort to learn than Ms-Access. I am ready to spend whatever the time it requires. I believe you all will guide me. Thank you. For your information, I believe our network is under Firewall and all the latest things in securing networks

Post a reply

No one has replied yet! Why not be the first?

Sign in or Join us (it's free).


Why not write for us? Or you could submit an event or a user group in your area. Alternatively just tell us what you think!

Our tools

We've got automatic conversion tools to convert C# to VB.NET, VB.NET to C#. Also you can compress javascript and compress css and generate sql connection strings.

“Every language has an optimization operator. In C++ that operator is ‘//’”