Update NVARCHAR2 in Oracle 8.1.7 using VB

  • 17 years ago

    Dear all,


    I have tried to update an Oracle NVARCHAR2 with no success. I am connecting to the Oracle table which has a mixture of NVARCHAR2s and VARCHAR2s using ADODB.Connection and ADODB.Recordset objects from Visual Basic.


    When trying to AddNew/Update record I get an error from Oracle ORA-12704.


    I have tried to read the type of each field and I found out, for VB the NVARCHAR2 and VARCHAR2 is adVarChar while it should have been adVarWChar and adVarChar respectively.


    Has anyone come across this issue before?


    Thanks in advance,


    Achilleas

Post a reply

No one has replied yet! Why not be the first?

Sign in or Join us (it's free).

Contribute

Why not write for us? Or you could submit an event or a user group in your area. Alternatively just tell us what you think!

Our tools

We've got automatic conversion tools to convert C# to VB.NET, VB.NET to C#. Also you can compress javascript and compress css and generate sql connection strings.

“We better hurry up and start coding, there are going to be a lot of bugs to fix.”