Problem with Compaq Armada 1573DM

hardware Canada
  • 16 years ago

    (In case you don't know, it's a way outdated laptop. )
    I got this used recently and though the floppy and CD drives don't work, it seems good for my purposes. Unfortunately, it seems to have crashed. When starting up, I get the message "The following configuration changes have been made: No fixed disk present. F1=Save Changes, F2=Ignore Changes." I press F2 and the system attempts to read from the floppy drive (it won't try the HD at all), only to come to the all-too-common "Non-system disk" error. I also can't seem to hear the HD spinning up anymore (I usually can, by removing the keyboard). The access light does come on as normal, however. (I did notice before that when using DOS, the light would be on all the time, but in Windows it acted normally. I never actually had disk problems.) Since the floppy and CD drives are toast I can't use a boot disk. Is there some way to get this thing working again?
    Also, how the hex do I get into the BIOS? I've done it before by mashing all of the F-keys, but that's not working anymore (probably because I set a boot password). >_< I'm not really sure which key does it.

  • 16 years ago
    Hi HyperHacker,

    Most of the newer compaq models allow you to get into the BIOS by pressing either f10 or f12 when the compaq splash screen appears.  If this doesn't work you can always try removing one of the RAM chips and re-installing it.  This will force you to accept the BIOS changes, therefore  allowing you to get into the BIOS.

    Colin
  • 16 years ago

    This model doesn't actually have a splash screen, it just displays a memory test. I could change the RAM but I want this to be a last resort as I'm inexperienced in laptop hardware.

  • 16 years ago

    I would suggest looking on the internet (maybe compaq's (hp's) site) to get instructions on how to get into the BIOS or at least you could find some instructions on how to safely remove RAM from your particular laptop.  Sorry I couldn't be of any more help.

  • 16 years ago

    Hey, I fixed it. Turns out this is one of those old hard drives that only works when it's actually connected. It seemed to have come loose somehow. Still dunno how to get into the BIOS though, Google's not helping much.

  • 15 years ago


    Hi!!


    How did you ever discover haw to get into the BIOS in the end? I have the same computer but with working floppy and cd drives. I want to boot from the cd drive but the boot sequence seems to be floppy - HD so I can't. AND I can't get into the danm BIOS and google is no help.


    Any other way to chenge the boot sequence? Do floppys boot disks exist that redirect the boot to the cd drive?


    Thanks a lot!

  • 14 years ago

    Compaq was the last hold out for flash BIOS
    To access the bios on most older Compaq machines, you will need a bootable Bios disk, or you will need to install the PC test and Start up on the hard drive (requires windows to be working)  With out the original install disks, Compaq made it quite impossible to setup one of these older machines.  This is how they stayed in business so long, you were required to contact their field service, who with the proper disk in hand,  could access and repair you machine.


  • 14 years ago

    i have very close model - armada 1573d. i had download a disk with rompaq:
    http://h18007.www1.hp.com/support/files/Armada/us/download/8077.html
    but i doesn't seem to work on "d" - it says, there is no bios image for this hardware.
    as for the Setup program, you need two disks. setup:
    http://h18007.www1.hp.com/support/files/Armada/us/download/8093.html
    and diagnostics:
    http://h18007.www1.hp.com/support/files/Armada/us/download/9260.html
    download, run the execs from hdd and make two disks. boot from setup disk and pick "install setup..." this will create a small fat12 partition on your hdd, which you can access after the memory test by pressing f10.(just when you see blinking cursor at the upper RIGHT of the screen for a few seconds).
    you can install diagnostics the same way: "manage diagnostic partition", then "install..." or "upgrade diagnostic partition".
    So, i have setup program, version 2.01 H   (24 Jan 99), but i can't find any memory chip working on it - everything is ok, but i want to put some more RAM to the slot - nothing works and in setup program there is no way to change the properties of ram.
    Does anyone know how to make ram work on 1573D? I have 64MB / 66 MHz. After putting it into a slot nothing is happening. I have tried many 100Mhz and 133MHz chips - no results.
    Can anyone help me?














Post a reply

Enter your message below

Sign in or Join us (it's free).

Contribute

Why not write for us? Or you could submit an event or a user group in your area. Alternatively just tell us what you think!

Our tools

We've got automatic conversion tools to convert C# to VB.NET, VB.NET to C#. Also you can compress javascript and compress css and generate sql connection strings.

“A computer is a stupid machine with the ability to do incredibly smart things, while computer programmers are smart people with the ability to do incredibly stupid things. They are, in short, a perfect match” - Bill Bryson