Epson C82 nozzle blocked?

hardware United Kingdom
  • 13 years ago

    Hi,


    I've got an Epson Stylus C82 color printer.  The yellow nozzle seems to be blocked - I've tried cleaning it using the in-built maintenance but the print check pattern stays the same.


    I printed out part of a road map for my brother and everything blue came out green and some of the other colors seemed a little off.


    The yellow ink cartridge is an Epson cartridge and is almost new.


    Does anyone know any little tricks to get something like this working without having to take it to a shop to get sorted?


    Just tried printing a solid yellow square (500x500, 72dpi, 0xffff00) and it came out... with a few grey dots!)


    Many thanks

  • 13 years ago

    Hi Zeb,


    There is not much you can do with the tools you get in the printer driver, they will not unblock a well blocked nozzle.
    There is a utility you can download which may help.


    If you go to www.ssclg.com (it is in Russian, but don't worry)
    Go to the Right hand side and you will see an entry that says Epson CSIC Utility Click this.
    On the next page click on English Version at the top.
    Scroll to the bottom and download the utility.


    Try this, i have used it a few times and it seems OK and has worked.


    Stryder

  • 13 years ago

    lol thanks for the reply, I've given up on the printer now and am about to bin it as the printer is screwed.

Post a reply

Enter your message below

Sign in or Join us (it's free).

Contribute

Why not write for us? Or you could submit an event or a user group in your area. Alternatively just tell us what you think!

Our tools

We've got automatic conversion tools to convert C# to VB.NET, VB.NET to C#. Also you can compress javascript and compress css and generate sql connection strings.

“The generation of random numbers is too important to be left to chance.” - Robert R. Coveyou