unable to Build my project, any help

.net Ethiopia
  • 11 years ago

    I build my project and run it successfuly. Then i added a setup and tried to build it. It faild. it shows a message 'unable to build assamby named 'xyz.exe', HRESULT == '8007064F'.

    I read that the character  " ' " which may found in the project name may cause this error.  actually there was one and i removed it, but the error is still there.

    Any help



  • 11 years ago
    Maybe some more informations would be necessary for others to understand conditions.

  • 11 years ago

    Well the thing is in my project there are crystal reports (embeded), sql data access codes, forms, and one DLL call which is an inherited control. I don't know which one cause a problem if it comes from these parts. I tried to say in my last post the project runs successfuly and i tested each and every parts of my work.

    Some where on the internet i read apostrop could make such a problem but that didn't help me.

    That is all i can say but the work i have been doing couldn't be built to a setup project due to some unkown error.

    May be you understand my position and help me Konikula. Simply drop me a few ideas that lead to the remedy.

    thanks in advance.

  • 11 years ago

    Hello Konikula.

    any idea!

  • 11 years ago


    Which VB are you using, because if its VB .NET (2003) you have to add some mergemodules with some registry number or if you are using VB 2005 you have to install crystal reports framework to be able to run the reports.

    I don’t remember if mergemodules is how they are called but its something you add in your setup project.

  • 11 years ago

    Hi, lexian

    I am using vb.Net 2003. I already added the merge modules, the one is added by default but i added the remaning three manually. There is one named crystal_regwiz2003 which needs a licence key , that i already did too. I think i am doing good around here. but still i don't know what cause the error!!!!!!!!!!




  • 11 years ago

    read this one,

    The only thing I could find that caused this error is if the Assembly Name or Project Name has a single quote in it's name. Your error message makes me think you don't have that scenario, but I would look to see if there is anything else interesting like that about the assembly name, or even the path it's in/on.

    This explanation Given by,
    David Guyer MS..
  • 11 years ago

    Hello All

    Finally it works. I took all parts of my project, forms, DLL, etc to a new Project with a simple name that doesn't include any quote. Then it works.

    Previously I think some where in the soultion the quote left unchanged even if i renamed the project name in to simpler one in the solution explorer, if the quote is the problem at all.

    But still my question is How the quote causes this problem???


Post a reply

Enter your message below

Sign in or Join us (it's free).


Why not write for us? Or you could submit an event or a user group in your area. Alternatively just tell us what you think!

Our tools

We've got automatic conversion tools to convert C# to VB.NET, VB.NET to C#. Also you can compress javascript and compress css and generate sql connection strings.

“The generation of random numbers is too important to be left to chance.” - Robert R. Coveyou